You are required to do this browser-based e-learning by this deadline or else. And BTW, all your current web browsers are not compatible with this e-learning module.

The company I work in has made it mandatory for all employees to undergo an e-learning course about a certain data protection law.

That is well and fine. There had been several e-learning courses before this, and there had not been any issue.

The problem with THIS e-learning is that it requires the use of web browsers that are outdated, and on many computers, have been superseded by browsers many, many versions newer.

My office colleague several days ago informed me that he had contacted the IT people responsible for the e-learning module, and was told to DOWNGRADE his web browser before he can participate in the mandatory e-learning.

Since I was occupied with something else then, I did not pay much attention to my colleague’s complaints. Only last night I realized what he said was true.

EL_PDPA_cannot log via firefox 34_uses broken security protocolLogging into the company’s portal using my Firefox browser, I was greeted with a big splash error message – “Unable to Connect Securely….(the site) uses SSLv3, a broken security protocol”.

Then I remembered about my colleague’s complaints. I opened the Guideline attached in an email sent by the company reminding everyone to complete the e-learning and warning of the consequences of not completing by the deadline.

I was shocked. The Guideline recommended the use of Internet Explorer 8.0 which has been superseded by IE 9 in March 2011. In December 2014 the current version is IE 11.

Similar thing for Firefox. the version tested OK with the company’s e-learning portal was Firefox 3.6, released in January 2010. In December 2014 the current version is Firefox 34.

And not much different for Google Chrome. The IT experts recommended Chrome 16.08, which was released way back in October 2011 and had since been superseded by Chrome 39.

And the worst part is, the mention in the Guideline of Netscape Navigator, which had been dead (not supported by its developers) since 2008.

EL_PDPA_computer requirements_outdated apps

 

 

 

 

 

 

 

 

 

 

I could not help wondering, WHEN was the Guideline first created that it did not take account of compatibility of the e-learning module with current browser versions ?

Surprise. The Guideline was created in May 2014, and last modified in September 2014.

What is going on?

I spent virtually the whole night searching the internet for the required legacy browser versions, installing them into my computer, testing, running and failing the e-learning run for 4 times, then updating my Flash Player and Java, before I could see it working.

I would like to wish that other people in the company could doggedly solve the problem the way I did.

But maybe not.

Looking at the report of people in my division who had completed the e-learning, the percentage was very, very low – less than 2% as of the middle of December 2014.

No wonder.

You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

Leave a Reply

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>